Overview
News
Salaries
Products
People
Growth
Offices
Financials

Overview

The official home of RFCs. RFCs outline computer networking and Internet foundations, including Internet Standards and historical or informative content.

News

Blog 2 months ago
RFC 10001: Operational Guidelines for DNS Transport in Mixed IPv4/IPv6 Environments
This document provides guidelines and documents best current practice for operating authoritative DNS servers, recursive resolvers, and stub resolvers in a mixed IPv4/IPv6 environment. This document recommends that both authoritative DNS servers and recur
Read more
Report
Blog 2 months ago
RFC 10006: Automatic SIP Trunking and Peering
This document specifies a framework that enables enterprise telephonySession Initiation Protocol (SIP) networks to solicit and obtain acapability set document from a SIP service provider. The capabilityset document encodes a set of characteristics that en
Read more
Report
Blog 2 months ago
RFC 10027: Best Current Practice for Security of Cross-Device Flows
This document describes threats against cross-device flows along with practical mitigations, protocol selection guidance, and a summary of formal analysis results identified as relevant to the security of cross-device flows. It serves as a security guide
Read more
Report
Blog 2 months ago
RFC 10024: Post-Quantum Traditional (PQ/T) Hybrid Key Agreement Mechanisms for TLS 1.3
This document defines three hybrid key agreement mechanisms for TLS 1.3 -- X25519MLKEM768, SecP256r1MLKEM768, and SecP384r1MLKEM1024 -- that combine the post-quantum ML-KEM (Module-Lattice-Based Key Encapsulation Mechanism) with an ECDHE (Ephemeral Ellipt
Read more
Report
News rfc-editor.org 2 months ago
RFC 9846: The Transport Layer Security (TLS) Protocol Version 1.3
This document specifies version 1.3 of the Transport Layer Security(TLS) protocol. TLS allows client/server applications to communicateover the Internet in a way that is designed to prevent eavesdropping,tampering, and message forgery. This document obsol
Read more
Report
News rfc-editor.org 2 months ago
RFC 9851: TLS 1.2 is in Feature Freeze
Use of TLS 1.3, which fixes some known deficiencies in TLS 1.2, is growing. This document specifies that no changes will be approved for TLS 1.2 outside of urgent security fixes (as determined by TLS Working Group consensus), new TLS Exporter Labels, and
Read more
Report
News rfc-editor.org 2 months ago
RFC 10015: Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2
For (D)TLS 1.2, this document deprecates the use of two key exchanges, namely Diffie-Hellman (DH) overa finite field and RSA. It also discourages the use of static Elliptic Curve Diffie-Hellman (ECDH)cipher suites. These prescriptions apply only to (D)TLS
Read more
Report
News rfc-editor.org 2 months ago
RFC 9987: Secure Shell (SSH) Agent Protocol
This document specifies a key agent protocol for use in the Secure Shell (SSH) protocol.
Read more
Report
Blog 3 months ago
RFC 10029: DNS Multiple QTYPEs
This document specifies a method for a DNS client to request additional DNS record types to be delivered alongside the primary record type specified in the Question section of a DNS QUERY (OpCode=0).
Read more
Report
News rfc-editor.org 3 months ago
RFC 8890: The Internet is for End Users RFC Editor
This document explains why the IAB believes that, when there is a conflict between the interests of end users of the Internet and other parties, IETF decisions should favor end users. It also explores how the IETF can more effectively achieve this.
Read more
Report
Show more news